PR
スポンサーリンク

【解決】UR22C,AG03音飛びプチプチAudio interruption due to USB error is detected. 他にMOTU M2,UAC-232,UAC-2

苦節1年ちょいで解決


『Audio interruption due to USB error is detected. Refer to the troubleshooting in the operation manual.』

この文字を見なくなるのは感慨深いなぁ、、と思えるほど何百回この文字を見たことか。ストレスを感じたことか、、、
先日とうとう私の環境ではこの問題が解決できました

簡単に書くと、私の環境はLenovoのデスクトップ、よく言われる原因のグラボはNVIDIA GTX 1660 SUPER、オーディオインタフェースはYamaha Steinberg UR-22C
状況はよくある感じで、音楽とかYoutubeを見ているとプチプチ音が切れたり、音飛びがずっと続いている感じでした


解決できた原因があまり見たことがなかった原因だったので、さすがに放置しているブログでもちゃんと書いて世の中に報告しないといけないよな、ということで対処方法を書こうと思います

たぶんこんなローカルブログを見に来るような方たちですから、他の有名な対処方法はほとんどやってきている、という前提で書きます(来るとしたら新着とか期間を限定した感じ?かな)

あ、あと、このブログのコメント欄はメールアドレスとか不要で名前だけで書き込めるので、『同じ原因で解決した!』とか『有名どころ以外の対処方法で解決したよ』という方は書いてもらえると嬉しいです
自分が解決するまで、むっちゃくちゃ時間がかかったり、ホント泣きそうになったりしてたので、、、

原因

◆原因
で、一番先に原因を書いときます。
PC環境とか、色々な雑談は下にダラダラと書くので、よければ見ていってください

ちなみにあくまで『自分の環境では』ですのであしからず

自分の環境の原因は
PCオンボードの有線LANポート(RJ45)
でした

つまりは、有線LANをつないでネットしたり音楽を聴いていると、何の対処をしてもずーーーーっとプチプチしてたんだけど、

ある時、何度やったかわからないOSのクリーンインストールをやっている最中に、LANケーブルを抜いた状態で聴いてて気が付いたのよね

『あれ????直ってね????????』


衝撃
マジで衝撃を受けました

過去にも全部のケーブルを抜いて試してたつもりだったんだけど、やってなかったのかな、、、

ケーブル抜いて、Wi-Fiにして聞いてみると、きれいさっぱり音飛びもプチプチも消え去って、きれいなままの音が続きました

最近はWi-Fiの方が多い?のでもしかすると役に立たないかもしれないけれど、もし有線で全く治らない人はぜひ試してみて下さい

対処方法

◆対処法
さっき書いた通り、オンボードのLANポート(RJ45)を使うとエラーになるので使えません。のでネットに繋ぐために何かをしないといけないわけで

私はPCでWi-Fiを使うのが少しためらいがある(せっかく有線で700Mbps以上~出てるっていうこともある)ので、結局PCI-eスロットにTP-Linkの2.5Gbps LANカードを増設して使うことにしました。

、、、先にUSBカードを増設して使っていたのに、使えなくなった・・・もう一つくらい拡張スロットがあるPCにすればよかったorz

とりあえず伝えたいこと

他のサイトに飛ばれる前に、言いたいところだけ先にピックアップして箇条書き
ちなみに、これも自分の環境だけです。いろいろなサイトを巡って思うけれど『音がプチプチする』とか『音飛びする』とか起きている状況(結果)は同じものの、原因は思っている以上に違うみたい

- Yamaha Steinberg USB Driverのせいじゃなかった
実は私は途中でオーディオインタフェースをレンタルして数機種試してみました。音質に定評のあるMOTU M2、ZoomのUAC-232も借りて試しました。これ、結局現象は変わらずプチプチ、プチプチ、、、

つまり他メーカのオーディオインタフェースを使ったところで状況が変わらなかったということで、私の環境ではそもそも「YAMAHAのせい!」とか「UR22Cのせい!」ではなかったんだろうな、というところでした
本当にまったく同じようにプチプチ、プチプチしていたので

何が言いたいかというと『よくネットで見る原因や対処法じゃないところにも、結局原因がありそうだ』ということです。下にも書きますけど、Geforceグラボのせいでもなかったし

あ!ちなみにMOTU M2は評判通り音がよかったです
もし今の状態でUR22Cを代えることがあるならば、M2欲しい、、
それはどうでも良いか、、

ここを見る人で多いのはYAMAHAのAG-03でしょうかね?UR-22Cも同じドライバを使ってて「YAMAHAのオーディオインタフェース(ドライバ)のせいだからメーカ変えれば直るでしょ!!」と思う人が多いかな?と思います。

もしかすると実際はこれで直る人が多いのかもしれないけれど、数万円程度だから購入!→直らなかった、、、っていうのも結構メンタルブレイク。。。それならレンタルして試しても(確かにお金の無駄遣いかもしれないけど)良いのかな?ともちょっと思ったりします。

オーディオインタフェースレンタルは『パンダスタジオ』というところがあるのでチェックしてみてください。私も借りたところ。楽だった。
ただレンタルといっても1機種で数千円するので、買っちゃうかレンタルするかは任せるけれども。。。うーん。。

スポンサーリンク

- Zoom UAC-2だとプチプチしなかった
上で書いた通り、レンタルで他メーカのオーディオインタフェースに変えても状況が変わらなかったのは事実
ただ、原因とかは全くわからないんだけど、レンタルした中でZoomのUAC-2だけはプチプチしなかったのも併せて伝えておきます
有線ポートを使っているにもかかわらず、UAC-2だけはプチプチしませんでした

何の相性なんでしょうか、、、
ホントにわけわからん。。。

UAC-2はマイクの入力レベルがうまいこと自分に合わなかったんだよな。。。あれさえなければ、別にUAC-2でそのまま使っていたんだけど。



-NVIDIA Geforceグラフィックボードのせいでもなかった
これもよく言われる原因で、グラフィックボードが原因、、、もっと言うとNVIDIA Geforceでエラーが発生するというのをよく見るけれども、もう少し調べると結局AMDのRadeonでもなってる人を見ます

書くのを迷ったけれども、実はワタクシ、、グラフィックボードも変えております(マジでどんだけ悩んでるんだ、、、orz)
GTX 1660 SUPERから、Radeon RX7600に変えております。。
んで、グラボ交換して「これで治るか!!!」と電源ON!!さっそくYoutube再生!!!

プチプチぃ。。。。。

直らなかったんです。。
何やってんだ、、、これはさすがにめっちゃ凹んだ

そういうこともあるから、結果もわからず、もしかしたら直るかも!!と買っちゃう!!!というのはやめたほうがいいよ、やっぱり。
もったいないなぁ。。。



- たぶんメインの問題はマザーボード
これは完全に推測だけど、オンボードのLANポートが原因ってところから考えて、自分の原因はマザーボードとの相性?だったんだろうな、と思ってます。

実は自分の場合なぜか保証内だったにもかかわらず『メーカに戻してマザーボード交換をしてもらう』というのを、問い合わせすらしていなくて。
正直に言うと面倒だったし、パソコンがなくなってしまうのも嫌だったし、そもそもたぶん「USBの相性というもので保証は受けれないだろう」とかムチャクチャなんか諦めの境地みたいな理由でメーカ修理に出すのはやめてました。

メーカによってはマザーボード交換なんてしてくれないかもしれないけど、結構マザーボードが原因ってこともあるんじゃなかろうか、ということで

- ちゃんと再現する、、、
「ちょうど有線LANポートを使わなくなったときに解決されただけで、どうせ何かの原因でまた問題おきるんじゃないの??」
というツッコミをされる方、結構この問題にハマった方でしょう。
そうでしょうそうでしょう。

日々ネット検索して、新しい対処が出たら試してみて、、「あっ!!ちょっと頻度が減ったかも!!!」なんて思うけれども、少ししたら結局またもとに戻って、、、。
あぁ、私も何度そうであったか。

というのは置いといて、ちゃんとオンボードの有線LANポートを使い始めると、現象は再現しました。もちろんWi-Fiにすると直りますし、増設したPCI-eの2.5G LANカードでも直ってます。

オンボードRJ45を使った時だけ、もう、何をしても治りません。
これだけはわかってます。

ネットに転がってる対処法が全く通用しない場合も全然あるので、あきらめずにいろいろと試行錯誤してみてください。

PC環境(スペック)

それでは最後にどうでもよいかもしれないけど、私のPC環境を

CPU:インテル® Core™ i5-12400F プロセッサー ( P-core 2.50 GHz E-core 4.40 GHz)
OS:Windows 11 Home 64bit
グラボ:NVIDIA® GeForce® GTX 1660 SUPER™ 6GB GDDR6
 →AMD Radeon RX7600に変更
メモリ:16 GB DDR5-4800MHz (UDIMM) – (2 x 8 GB)
 →32GB に増設済み
ストレージ:512 GB SSD M.2 2280 PCIe Gen4/4 + 1 TB HDD 7200rpm 3.5″
 →HDDを増やしてるけど、あんまり関係なさそうだから割愛

まとめ


結局のところ、ネットに転がっている対策方法とかは本当にアホのようにやってみたし、自分の場合は上で書いたようにオーディオインタフェースは複数レンタルするわ、最終的には「ゲフォ(Geforce)が悪いんだろ!ゲフォ(Geforce)が!!!」となんの根拠もないくせにAMDのグラフィックボードに変えたりしたくせに、結局音飛び直らず、、、、、

というもう悶絶モノのバカをやり尽くしているので、直った時にはもう本当に自分がハゲてたら髪が生えてくるんじゃないかくらいの解放感で、ストレスが一気になくなりました

私の場合は、有線LANポート(有線LAN)を使うと現象が起きる、という聞いたことがないところに原因があったので、判明するまではもうとんでもなく時間がかかりました。

もし誰かの困っている方の参考になればうれしいです!!

最初のほうにも書きましたが、このコメ欄はアドレスも不要なので、ユーザ名「匿名」にでもしていただければなんでも書けます!
みんなでこの問題の解消法を集めましょう!!!

コメント